
<!DOCTYPE HTML>
<html lang="en">
    <head>
        <meta charset="utf-8" />
<link rel="shortcut icon" href="https://www.triplejunearthed.com/profiles/unearthed_profile/themes/unearthed_theme/favicon.ico" type="image/vnd.microsoft.icon" />
<meta name="description" content="Indigenous Hip Hop Emcee Lucky Luke ---(Joseph Luke Dargan) from North West Qld Australia is an independent rapper." />
<meta name="generator" content="Drupal 7 (http://drupal.org)" />
<link rel="canonical" href="https://www.triplejunearthed.com/artist/lucky-luke" />
<link rel="shortlink" href="https://www.triplejunearthed.com/node/5608716" />
<meta property="og:site_name" content="triple j Unearthed" />
<meta property="og:type" content="website" />
<meta property="og:url" content="https://www.triplejunearthed.com/artist/lucky-luke" />
<meta property="og:title" content="Lucky Luke" />
<meta property="og:description" content="Indigenous Hip Hop Emcee Lucky Luke ---(Joseph Luke Dargan) from North West Qld Australia is an independent rapper." />
<meta property="og:image" content="https://www.triplejunearthed.com/sites/default/files/artists/public/5/6/0/8/7/1/6//45fd68fc-36ea-46ce-9d20-c7bd3b3c8dc8.jpg" />
<meta property="og:image:secure_url" content="https://www.triplejunearthed.com/sites/default/files/artists/public/5/6/0/8/7/1/6//45fd68fc-36ea-46ce-9d20-c7bd3b3c8dc8.jpg" />
        <title>Lucky Luke | triple j Unearthed</title>
        <link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/sites/default/files/css/css_kShW4RPmRstZ3SpIC-ZvVGNFVAi0WEMuCnI0ZkYIaFw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/sites/default/files/css/css_d1NIvfrMrvj4QkZxF4Gygqa8-COYX0t4IIM5TrkYfb0.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/sites/default/files/css/css_PoSW6URjkFJGsSY989adhjpSNvHrQt0WyJLcec6N8_8.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/sites/default/files/css/css_p6pVbUpexrPjURtk5DHQskYFYOQSnjXUTlDBSdKs1fw.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://res.abc.net.au/bundles/2.0.9/styles/abc.bundle.2.0.9.min.css" media="all" />

<!--[if IE 8]>
<link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/profiles/unearthed_profile/themes/unearthed_theme/css/abc_unearthed_ie8.css?on6fkn" media="all" />
<![endif]-->

<!--[if lte IE 7]>
<link type="text/css" rel="stylesheet" href="https://www.triplejunearthed.com/profiles/unearthed_profile/themes/unearthed_theme/css/abc_unearthed_ie7.css?on6fkn" media="all" />
<![endif]-->
        <script src="https://www.triplejunearthed.com/sites/default/files/js/js_LcFRnnSHVah-Aw_WQ8aVLXhp3HPJvrOe4h6YEXA5BT8.js"></script>
<script src="https://www.triplejunearthed.com/profiles/unearthed_profile/modules/contrib/lightbox2/js/lightbox.js?1492868128"></script>
<script src="https://www.triplejunearthed.com/sites/default/files/js/js_RmM26TEFC0B2fd0tlbkmbTKrMdk86vgEQJLl_6-qgdw.js"></script>
<script>window.CKEDITOR_BASEPATH = '/profiles/unearthed_profile/libraries/ckeditor/'</script>
<script src="https://www.triplejunearthed.com/sites/default/files/js/js_LGlcLxTBSqJcvXh1d6Qa2gd5f_S1GRO1yQPiI4N8jow.js"></script>
<script>jQuery.extend(Drupal.settings, { "pathToTheme": "profiles/unearthed_profile/themes/unearthed_theme" });</script>
<script src="https://www.triplejunearthed.com/sites/default/files/js/js_f0qcRf2LFGetevtwJn-feHesR9xwamjI_bMJUFSyBwU.js"></script>
<script>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</script>
      <meta name="apple-itunes-app" content="app-id=348746923">
    </head>
    <body class="html not-front not-logged-in no-sidebars page-node page-node- page-node-5608716 node-type-unearthed-artist section-artist page-panels" >
        <div id="skip-link">
            <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
        </div>
                

<div id="artist_profile" class="profile"><div id="wrapper">
  
    <nav id="abcHeader" class="global" role="navigation" aria-label="ABC Network Navigation" data-resourcebase="https://res.abc.net.au/bundles/2.0.9/" data-scriptsbase="https://res.abc.net.au/bundles/2.0.9/scripts/" data-version="2.0.9">
      <a class="abcLink home" href="http://www.abc.net.au/" data-mobile="http://mobile.abc.net.au/"><img src="https://res.abc.net.au/bundles/2.0.9/images/logo-abc@2x.png" width="72" height="18" alt="">ABC Home</a>
      <div class="sites">
        <a class="controller" href="javascript:;" aria-controls="abcNavSites"><img src="https://res.abc.net.au/bundles/2.0.9/images/icon-menu-grey@1x.gif" data-src="images/icon-menu-grey@1x.gif" data-hover="images/icon-menu-blue@1x.gif" class="icon" alt=""><span class="text"><span>Open</span> Sites <span>menu</span></span></a>
        <div id="abcNavSites" class="menu" role="menu" aria-expanded="false">
          <ul>
            <li class="odd"><a class="abcLink" role="menuitem" href="http://www.abc.net.au/" data-mobile="http://mobile.abc.net.au/">ABC Home</a></li>
            <li><a class="abcLink" role="menuitem" href="http://www.abc.net.au/news/" data-mobile="http://mobile.abc.net.au/news/">News</a></li>
            <li class="odd"><a class="abcLink" role="menuitem" href="http://www.abc.net.au/iview/" data-mobile="http://www.abc.net.au/iview/">iview</a></li>
            <li><a class="abcLink" role="menuitem" href="http://www.abc.net.au/tv/" data-mobile="http://www.abc.net.au/tv/">TV</a></li>
            <li class="odd"><a class="abcLink" role="menuitem" href="http://www.abc.net.au/radio/" data-mobile="http://www.abc.net.au/radio/">Radio</a></li>
            <li><a class="abcLink" role="menuitem" href="http://www.abc.net.au/children/" data-mobile="http://mobile.abc.net.au/children/">Kids</a></li>
            <li class="odd"><a class="abcLink" role="menuitem" href="https://shop.abc.net.au/" data-mobile="https://shop.abc.net.au/">Shop</a></li>
            <li><a class="abcLink more" role="menuitem" href="http://www.abc.net.au/more/" data-mobile="http://www.abc.net.au/more/">More</a></li>
          </ul>
        </div>
      </div>
      <div class="accounts">
        <!-- Accounts is currently injected due to different URLs --><span data-src="images/icon-user-grey@1x.png" data-hover="images/icon-user-blue@1x.png"></span>
      </div>
    </nav>

    <header id="unearthed_header">
      <div class="left">
        <a href="/" id="logo_triplejunearthed" title="triple j unearthed">triple j unearthed</a>
        <h1 class="slogan">discover new australian music</h1>
      </div>
      <div class="right">
        <ul class="header-menu">
                      <li>
              <a href="/user/login" title="Sign in">Sign in</a>            </li>
                      <li>
              <a href="/user/register" title="Register">Register</a>            </li>
                  </ul>
        <form action="/artist/lucky-luke" method="post" id="search-block-form" accept-charset="UTF-8"><div><div class="container-inline">
      <h2 class="element-invisible">Search form</h2>
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2"> Search</label>
 <input title="Enter the terms you wish to search for." placeholder="search Unearthed" type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="" class="form-submit" /></div><input type="hidden" name="form_build_id" value="form-pauv7wXDOBKqu7esXQv-aXwLRfabvWx41XT6TItlLM8" />
<input type="hidden" name="form_id" value="search_block_form" />
</div>
</div></form>      </div>
    </header>
    <nav id="unearthed_main_menu">
      <ul><li class="0 first has-sub "><a href="/discover/tracks">Music</a>
    <ul class="submenu">
      <li>
        <span class="title">feature artists</span>
        <span class="text">each week we feature the best artists for you to discover</span>
        <a href="/discover/artists?featured=featured">view artists</a>
      </li>
      <li>
        <span class="title">played on triple j</span>
        <span class="text">the latest Unearthed tracks played on triple j radio</span>
        <a href="/discover/tracks?played=triplej">view tracks</a>
      </li>
      <li>
        <span class="title">played on unearthed</span>
        <span class="text">the latest tracks played on our digital radio station</span>
        <a href="/discover/tracks?played=unearthed">view tracks</a>
      </li>
    </ul>
  </li>
<li class="1 has-sub"><a href="/discover/reviews">Reviews</a>
    <ul class="submenu">
      <li>
        <span class="title">triple j team</span>
        <span class="text">see what triple j presenters and staff rate this week</span>
        <a href="/discover/reviews?featured=triplej">view reviews</a>
      </li>
      <li>
        <span class="title">guest hosts</span>
        <span class="text">see what the guests dropping by our studios are loving</span>
        <a href="/discover/reviews?featured=guest">view reviews</a>
      </li>
      <li>
        <span class="title">super users</span>
        <span class="text">see what our most enthusiastic users have to say</span>
        <a href="/discover/reviews?featured=super-user">view reviews</a>
      </li>
    </ul>
  </li>
<li class="2"><a href="/discover/playlists">Playlists</a></li>
<li class="3 has-sub"><a href="/digital-radio">Programs</a>
    <ul class="submenu">
      <li>
        <span class="title">tops</span>
        <span class="text">Listen in to hear the Unearthed crew play you the best new sounds before anybody else!</span>
        <a href="/program/tops">view tops</a>
      </li>
      <li>
        <span class="title">amped</span>
        <span class="text">Every track you hear on Amped comes from an act playing live this weekend!</span>
        <a href="/program/amped">view amped</a>
      </li>
      <li>
        <span class="title">handpicked</span>
        <span class="text">We let your favourite music makers and music lovers take over the radio to play their Unearthed favs.</span>
        <a href="/program/handpicked">view handpicked</a>
      </li>
      <li>
        <span class="title">monthly mixtape</span>
        <span class="text">The Monthly Mixtape is another chance for you to wrap your ears around the best new music from the month that was.</span>
        <a href="/program/monthly-mixtape">view Monthly Mixtape</a>
      </li>
    </ul>
  </li>
<li class="4"><a href="/comps-and-resources/resources">Articles</a></li>
<li class="5"><a href="/discover/gigs">Gigs</a></li>
<li class="6"><a href="/discover/charts">Charts</a></li>
<li class="7 last"><a href="/comps-and-resources/competitions">Competitions</a></li>
</ul>      <div class="digital-radio">
        <a href="#" class="launch-unearthed-drp">
          <span class="listen-button"></span>
          <span class="listen-text">listen to live</span>
          <span class="digital-radio-text">digital radio</span>
        </a>
      </div>
    </nav>
    
  <section class="profile-header">
    <div class="top">
      <div class="image">
        <a href="/node/5608716">
          <img src="https://www.triplejunearthed.com/sites/default/files/styles/unearthed_medium/public/artists/public/5/6/0/8/7/1/6//45fd68fc-36ea-46ce-9d20-c7bd3b3c8dc8.jpg?itok=rMESKJrs" alt="Lucky Luke ">
        </a>
      </div>
      <div class="profile-content-wrapper view-id-artist_profile_info">
        <h1 id="unearthed-profile-title">Lucky Luke </h1>
        <div class="top-row-content">
<div class="upper-wrapper">
  <div class="label"><span class="genres location"><span class="genre">Hip Hop</span> - <span class="location">North West Queensland, QLD</span></span></div>
      <div class="social followers_outline">
      <div class="followers_wrapper">
        <span class="hidden">Followers</span>
        <div class="followers"></div>
      </div>
            <a class="connect" title="Contact artist" href="/connect_with_artist/5608716" rel="lightframe [|width:600px; height:550px;]">Contact</a>      <a class="share" title="Share" href="/share_artist?artist_id=5608716" rel="lightframe [|width:700px; height:630px;]">Share</a>    </div>
  </div>
  <div class="track_boxes">
    <div class="track_box">
  <div class="track_name" title="Another Day feat Skank ">Another Day feat Skank </div>
  <div class="track_box_icons">
      <div class="icons mature" title="Strong impact coarse language and/or themes">Strong impact coarse language and/or themes</div>
      <div class="icons unearthed" title="Played on unearthed">Played on unearthed</div>
    </div>

  <div class="date_uploaded">Uploaded 30 Dec 16</div>

  
  <div class="play_actions">
    <ul>
      <li><a href="/jukebox/play/track/5608766" class="play_now_large open_jukebox">Play now</a></li>
      <li class="popover optionsmenu">
        <a href class="play_add_large options tbutton">Options</a>
        <ul class="optionspopover menu">
          <li class="option"><a href="/jukebox/queue/track/5608766" class="plus open_jukebox">Add to listening queue</a></li>
          
          <li class="option"><a href="/share_artist?artist_id=5608716" class="share" rel="lightframe [|width:700px; height:588px;]">Share &amp; embed</a></li>
          <li class="option last"><a href="/download/track/5608766" class="download">Download this track</a></li>
        </ul>
      </li>
    </ul>
  </div>
  
  <ul class="track_details">
        <li>
      <div class="labels label_rating">Ratings</div><p>avg rating</p><p class="value stars_sm stars_sm_40">40</p>
    </li>
    <li>
      <div class="labels review">Reviews</div><p class="reviews">reviews</p><p class="value">11</p>
    </li>
    <li>
      <div class="labels play">Plays</div><p class="plays">plays</p><p class="value">487</p>
    </li>
    <li>
      <div class="labels download">Downloads</div><p class="downloads">downloads</p><p class="value">162</p>
    </li>
    <li>
      <div class="labels love">Loves</div><p class="loves">loves</p><p class="value">4</p>
    </li>
    <li>
      <div class="labels share">Shares</div><p class="shares">shares</p><p class="value">6</p>
    </li>

  </ul>
</div>
<div class="track_box">
  <div class="track_name" title="Jacks ">Jacks </div>
  <div class="track_box_icons">
      <div class="icons mature" title="Strong impact coarse language and/or themes">Strong impact coarse language and/or themes</div>
      <div class="icons playedontriplej" title="Played on triple j">Played on triple j</div>
      <div class="icons unearthed" title="Played on unearthed">Played on unearthed</div>
    </div>

  <div class="date_uploaded">Uploaded 30 Mar 17</div>

  
  <div class="play_actions">
    <ul>
      <li><a href="/jukebox/play/track/5858731" class="play_now_large open_jukebox">Play now</a></li>
      <li class="popover optionsmenu">
        <a href class="play_add_large options tbutton">Options</a>
        <ul class="optionspopover menu">
          <li class="option"><a href="/jukebox/queue/track/5858731" class="plus open_jukebox">Add to listening queue</a></li>
          
          <li class="option"><a href="/share_artist?artist_id=5608716" class="share" rel="lightframe [|width:700px; height:588px;]">Share &amp; embed</a></li>
          <li class="option last"><a href="/download/track/5858731" class="download">Download this track</a></li>
        </ul>
      </li>
    </ul>
  </div>
  
  <ul class="track_details">
        <li>
      <div class="labels label_rating">Ratings</div><p>avg rating</p><p class="value stars_sm stars_sm_40">40</p>
    </li>
    <li>
      <div class="labels review">Reviews</div><p class="reviews">reviews</p><p class="value">17</p>
    </li>
    <li>
      <div class="labels play">Plays</div><p class="plays">plays</p><p class="value">1106</p>
    </li>
    <li>
      <div class="labels download">Downloads</div><p class="downloads">downloads</p><p class="value">181</p>
    </li>
    <li>
      <div class="labels love">Loves</div><p class="loves">loves</p><p class="value">2</p>
    </li>
    <li>
      <div class="labels share">Shares</div><p class="shares">shares</p><p class="value">11</p>
    </li>

  </ul>
</div>
  </div>
</div>
      </div>
    </div>
          <div class="bottom"><ul class="menu"><li class="menu__item is-leaf first leaf"><a href="/artist/lucky-luke" class="menu__link active">Profile</a></li>
<li class="menu__item is-leaf leaf"><a href="/artist/5608716/gigs" class="menu__link">Gigs</a></li>
<li class="menu__item is-leaf leaf"><a href="/artist/5608716/reviews" class="menu__link">Reviews</a></li>
<li class="menu__item is-leaf last leaf"><a href="/artist/5608716/followers" class="menu__link">Followers</a></li>
</ul></div>
      </section>
  
  
    <div id="main">
    <div id="content" class="column" role="main">
      <div id="content-unearthed">
        <div class="content_inner">
          
            <div >
              <a id="main-content"></a>
              



<div class="panel-display panel-artist-profile clearfix" >

  <div class="panel-panel panel-col-first">
    <div class="inside"><div class="panel-pane pane-block pane-views-artist-info-block" >
  
      
  
    <div class="content_module module_artistinfo">
    <h2>Artist info</h2>

          <div class="panel">
        <h3>Genre</h3>
        <p>Hip Hop</p>
        <hr>
      </div>
    
        <div class="panel tags">
      <h3>Tags</h3>
      <p><a href="/search/node/currymurri13">currymurri13</a> <a href="/search/node/Lucky Luke">Lucky Luke</a> <a href="/search/node/Mount Isa">Mount Isa</a> <a href="/search/node/hip hop">hip hop</a> <a href="/search/node/rap">rap</a></p>
      <hr>
    </div>
    
        <div class="panel">
      <h3>Sounds like</h3>
      <p>Sounds like no one else</p>
      <hr>
    </div>
    
        <div class="panel">
      <h3>band members</h3>
      <p>Joseph Dargan - Lucky Luke,
 Joe Ave- DJ, 
Dave Marsalis - Drums
</p>
      <hr>
    </div>
    
        <div class="panel">
      <h3>Influences</h3>
      <p>Method Man , Naughty By Nature, 2pac, Nas , Jay Z , Chance the Rapper , Anderson .Paak , Slim Dusty , Rodriguez, Bob Dylan </p>
      <hr>
    </div>
    
        <div class="panel">
      <h3>Unearthed artists we like</h3>
      <p><a href="/artist/tera">TERA</a>, <a href="/artist/stinga-t">Stinga T</a></p>
      <hr>
    </div>
    
    <div class="panel">
      <h3>Website</h3>

              <p><a href="http://www.luckyluke.com.au">www.luckyluke.com.au</a></p>
      
      <ul class="social">

                <li class="facebook">
          <div class="icons facebook">Facebook</div>
          <a href="https://www.facebook.com/currymurri13/">Facebook</a>        </li>
        
                <li class="twitter">
          <div class="icons twitter">Twitter</div>
          <a href="https://twitter.com/JoeD213">Twitter</a>        </li>
              </ul>
    </div>
  </div>

  
  </div>
<div class="panel-pane pane-block pane-views-artist-gig-block-block" >
  
      
  
  <div class="view view-artist-gig-block view-id-artist_gig_block view-display-id-block view-dom-id-ead05cf4bf6822dcc2376fc2df1c81a3">
        
  
  
      <div class="view-content">
      <div class="content_module module_gig">
  <div class="outline">
    <h3>Gig</h3>
        <p class="band">

      <a href="/artist/lucky-luke">Lucky Luke </a>
    </p>

    <div class="icons mature" title="Strong impact coarse language and/or themes">
      Strong impact coarse language and/or themes
    </div>

    
    <div class="separator"></div>
    <div class="gig">
      <p class="date">
        22 Apr      </p>
            <p class="venue">
        One Night Stand 2017
      </p>
            <p class="region">
        North West Queensland, 4825      </p>
                  <p class="region">
        MOUNT ISA      </p>
            <p class="time">
        7:00pm      </p>
    </div>
  </div>  
  <div class="footer220"></div>
</div>

<div class="content_module module_gig">
  <div class="outline">
    <h3>Gig</h3>
        <p class="band">

      <a href="/artist/lucky-luke">Lucky Luke </a>
    </p>

    <div class="icons mature" title="Strong impact coarse language and/or themes">
      Strong impact coarse language and/or themes
    </div>

    
    <div class="separator"></div>
    <div class="gig">
      <p class="date">
        22 Apr      </p>
            <p class="venue">
        The Rish Nightclub
      </p>
            <p class="region">
        North West Queensland, 4825      </p>
                  <p class="region">
        MOUNT ISA      </p>
            <p class="time">
        11:00pm      </p>
    </div>
  </div>  
  <div class="footer220"></div>
</div>

    </div>
  
  
  
  
  
  
</div>
  
  </div>
</div>
  </div>
  
  <div class="panel-panel panel-col-second">
    <div class="inside"><div class="panel-pane pane-block pane-views-artist-bio-block" >
  
      
  
  <div class="view view-artist-bio view-id-artist_bio view-display-id-block view-dom-id-c6aff78e9e289f56fc6c5eabaf8f383d">
        
  
  
      <div class="view-content">
      <div class="content_module module_artistbio">
  <div class="outline">
    <h3>Bio</h3>   
          
  <div class="views-field views-field-field-artist-bio">        <div class="field-content"><p>I am really proud to have been chosen as the One Night Stand winner for my Track 'Jacks'. I cant wait to Hip Hop all over that stage and represent for my homies in THE ISA!! One Night Stand 2017 see you Saturday 22 April in Mount Isa!</p>
<p>Joseph Dargan AKA Lucky Luke is a Hip Hop artist from Mount Isa, born in Cloncurry, QLD. Lucky Lukes inspiration and fighting spirit draws from his life experiences. His ancestry spans from the Northern Territory of Warumungu country to further south of the Ringa Ringa group, to the country of the Mighty Mitakoodi and the Kalkadoons and along to his home of the Waanyi people.</p>
<p>Since the release of the first album Whichway earned Triple J rotation for singles ‘Send me to my Grave’ and ‘1day’ which was nominated in the Triple J hottest 100. He then released his second album ‘Playin’ da blk card’ late 2015. </p>
<p>Lucky Luke has an uncanny sense for a dope beat and word play.  A gift of storytelling and lyricism, each song speaks a narrative. Lucky Luke is gifted with a unique flow and the power of expression that shapes his tracks based on life and the passion for his people and community. In “Send me to my grave” off the Whichway album he dedicates a special heartfelt oral history verse of his grandfather’s struggle and survival. </p>
<p>Lucky Lukes albums feature collaborations with JPoint, Auriel Andrew, Dice Hip Hop, Joe Ave, RazzyMak, Na-Palm and BoZzA. In January 2017 he released ‘Gone4ever feat. Rahjconkas’. In June 2017 he’ll release ‘MY STEREO’, a single with female Hip Hop duo ‘Coda Conduct’ and in April 2017 new single ‘JACKS’ a tribute to a community in Mount Isa“.</p>
<p>In 2015 Lucky Luke was a standout at the NIMA awards nominated for best talent. He kicked off 2017 by performing in Australia’s biggest Aboriginal and Torres Strait Islander Major festival ‘Yabun’ to an audience of 35,000 people in Sydney.<br />
Lucky Luke is supporting American Hype Man Fatman Scoop in Mount Isa, Qld in May 2017 and is currently working on his third album ‘Walkabout’ due for release December 2017.</p>
<p>Currently working on a new album and a 2017/18 tour with his crew:<br />
 Joe Mackay (Jo Ave) DJ and rapper who hones 10 plus years in  the music industry as producer and label owner and member of collective ‘Born Fresh Records’ aka Hip Hop artist ‘Eloquence’. </p>
<p>Dave Marsalis, nationally respected drummer who has recorded and toured with Archie Roach, Christine Anu and Yothu Yindi and continues to play as a session drummer for man bands and is co host of the “funky lunch show” on Koori Radio 93.7fm.  </p>
<p>Lucky Luke is ready to roll out like a boss in 2017 and prepare for a busy year with singles “JACKS” and “My Stereo”, another album “Walkabout”, sick collaborations, planning tours - armed with a team who are as passionate about his music as Lucky Luke himself. </p>
<p>Enquiries to Danielle at <a href="mailto:Luckylukemusicau@gmail.com">Luckylukemusicau@gmail.com</a><br />
Spotify <a href="https://open.spotify.com/artist/3ct1QJgiejr2b8j1wHUH25">https://open.spotify.com/artist/3ct1QJgiejr2b8j1wHUH25</a><br />
Itunes <a href="https://itunes.apple.com/au/album/whichway/id974176589">https://itunes.apple.com/au/album/whichway/id974176589</a><br />
Video <a href="https://www.backbonemusic.com.au/video">https://www.backbonemusic.com.au/video</a></p>
</div>  </div>      </div>
  <div class="footer340"></div>
</div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-block pane-views-artist-video-content-block" >
  
      
  
  <div class="view view-artist-video-content view-id-artist_video_content view-display-id-block view-dom-id-c33c2c5c01ffa49d2d024739c923f34e">
        
  
  
      <div class="view-content">
      <div class="content_module module_video">
          <div class="outline">
            <iframe id="ytplayer" type="text/html" width="340" height="192" src="https://www.youtube.com/embed/uxCOSaw-icc?wmode=transparent" frameborder="0" allowfullscreen></iframe>
          </div>
          <div class="footer340"></div>
        </div>    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-block pane-views-artist-featured-block-block" >
  
      
  
  <div class="view view-artist-featured-block view-id-artist_featured_block view-display-id-block view-dom-id-9ef33abbd3fa5a77deaa326b786172c8">
        
  
  
      <div class="view-content">
      <div class="content_module module_featuredartist">
      <div class="artist">
      <h3>Featured Artist</h3>
      <div class="date">
        <p class="year">
          2017        </p>
      </div>
      <div class="date">
        <p class="day">
          17        </p>
        <p class="month">
          Apr        </p>
      </div>

      <h2 class="band"><a href="/artist/lucky-luke">Lucky Luke </a></h2>
              <ul class="genre">
          
              <li>
                <a href='/search/node/Hip Hop'>Hip Hop</a>
              </li>         </ul>
                  (
          <ul class="tag">
                        <li>
                            <a href="/search/node/currymurri13">currymurri13</a>
              ,            </li>
                        <li>
                            <a href="/search/node/Lucky Luke">Lucky Luke</a>
              ,            </li>
                        <li>
                            <a href="/search/node/Mount Isa">Mount Isa</a>
              ,            </li>
            ...          </ul>
          )
                    <p class="location">
            North West Queensland, QLD          </p>
                        </div>
              <div class="outline">
                                  <div class="article">
                    <p>Meet hometown hero <strong>Lucky Luke </strong>as he gets ready to blow up the stage this Saturday night at <strong>Triple J's One Night Stand</strong>, putting Mount Isa on the hip hop map.</p>                  </div>
                                    <div class="separator"></div>
                  <a class="show_hidden_sibling_section show_interview" href="#">Read Interview</a>
                  <div class="hide_hidden_sibling_section ">
                    <p class="answer">
                      <p><strong>Tell us about your music. How did you develop your sound?</strong></p><p>I grew up listening to all types of music in our home that gave me a history of understanding an appreciation of its origin. When I was younger I only listened to rap but because I was in this environment I was surrounded by different sounds and influences. <span style="font-size: 13.008px;">My parents liked watching music documentaries so I began to understand how different sounds were developed.</span></p><p><span style="font-size: 13.008px;">I began to understand how rap can make a change. For example, I remember my mum allowing us to buy a cd of the newly released NWA album but when we put it on and she heard all the swearing of police she wanted to break it and we said we can sell it. Secretly we kept it and listened to it.</span></p><p><span style="font-size: 13.008px;">Looking back I remember how they took the government to court for free speech. That was a big deal back in the day. I look at my music now and think of comments in the media like ‘ Aboriginals need to move on’ but in music I think you can put those messages out there time and time again and people will sing along and listen to it compared to someone in a protest singing out land rights.</span></p><p><span style="font-size: 13.008px;">My voice tends to be more calming and not at that high pitch and I don’t tend to pick beats that are fast and rap on with a list of words. </span></p><p><span style="font-size: 13.008px;">I want to be a storyteller. </span></p><p><span style="font-size: 13.008px;">I’m not sitting around the campfire telling a story but my listeners might be sitting around the campfire listening to me tell them that story. Our elders have put out our messages time and time again I am just trying to do that in another genre and that is rap.</span></p><p><strong>What makes you proud to be making the music you make today?</strong></p><p>I know the whole community are listening to my music whether they are young or old Aboriginal or non-indigenous.</p><p><strong>What’s your greatest source of inspiration for making music?</strong></p><p>My people’s struggle to be recognised in their own country and their struggle to be treated fairly.</p><p><strong>What can punters expect from a Lucky Luke live show?</strong></p><p>Nonstop music accompanied by a drummer and hype man that allows the listener to escape on an emotional storytelling journey.</p><p><strong>What’s the best advice you’ve been given and who was it from? </strong></p><p>My mum is a proud fan of mine and her advice and belief in me that I’m unique. I’m me I don’t have to rap or follow other’s people’s content, style or idea or what is rap I can follow through with my own ideas. I don’t have to conform to the masses.</p><p><strong>What Australian track would you play to cheer up someone who was crying?</strong></p><p>Powderfinger -<em> My Happiness </em></p><p><strong>W</strong><span style="font-size: 13.008px;"><strong>hat Australian track would you play to someone to make them cry?</strong> </span></p><p><span style="font-size: 13.008px;">Slim Dusty: Leave him out there in the long yard (My Grandfather always used to sing this song to us). </span></p><p><span style="font-size: 13.008px;"><strong>You’re the DJ at a party. The dance floor is pumping. What Australian track do you put on next? </strong></span></p><p><span style="font-size: 13.008px;">ACDC - Thunder struck </span></p><p><span style="font-size: 13.008px;"><strong>What was the last local gig you went to? How was it?</strong> </span></p><p><span style="font-size: 13.008px;">Seth Sentry, it was good even though there was only 80 people on a Thursday night. </span></p><p><span style="font-size: 13.008px;"><strong>Tell us about the bands or people in the Mount Isa music community that inspire you.</strong> </span></p><p><span style="font-size: 13.008px;">I don't really mix with other artist in Mount Isa, to tell the truth I just sit at home doing my own thing because I'd rather not be influenced by other artist.</span></p><p><span style="font-size: 13.008px;"><strong>Name 3 Unearthed Artist you recommend us checking out?</strong> </span></p><p><span style="font-size: 13.008px;">Tera – Better Dayz </span></p><p><span style="font-size: 13.008px;">Stinga T – Dreams </span></p><p><span style="font-size: 13.008px;">K.P - Hands up </span></p><p><span style="font-size: 13.008px;"><strong>Lastly, what are your plans for 2017?</strong> </span></p><p><span style="font-size: 13.008px;">Capital and outback tour, release of my third album. Work on designing and printing up merchandise for my tour. The creation of a website where people can book me not just for music gigs but for lessons in schools.</span></p>                    </p>
                    <div class="separator"></div>
                    <a class="view_profile" href="/artist/lucky-luke">View Profile</a>
                    <a class="hide_interview" href="#">Hide Interview</a>
                  </div>
                </div>
                <div class="footer340"></div>
              </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-views pane-competition-artist-block" >
  
      
  
  <div class="view view-competition-artist-block view-id-competition_artist_block view-display-id-block_1 view-dom-id-69706e8c89a43cd0bbbd1dded0561f75">
        
  
  
      <div class="view-content">
      <div class="content_module module_competitionwinner">
  <h4><span>Unearthed</span> in 2017</h4>
  <div class="head">
    <a href="/competition/triple-js-one-night-stand-2017" title="One Night Stand" class="comp_img"> <img src="/sites/default/files/styles/unearthed_competition_logo/public/competition_logo/public/5/8/3/0/3/0/1/22981041-4d35-463d-81f4-3eae0a5386f7.jpg" width="108" height="40" alt="One Night Stand" /> </a>
                  <p>
            02 Apr 2017          </p>
                    <h3 class="cufon_avm">Winner</h3>
          <h4 class="cufon_avm"><a href="/artist/lucky-luke" title="Lucky Luke ">Lucky Luke </a></h4>
        </div>
        <a class="photo" href="/artist/lucky-luke"> <img src="/sites/default/files/styles/unearthed_large/public/artists/public/5/6/0/8/7/1/6/45fd68fc-36ea-46ce-9d20-c7bd3b3c8dc8.jpg" width="338" height="225" alt="Lucky Luke " class="photo"> </a>
              <div class="outline">
                                  <h2>Lucky Luke to open up One Night Stand!</h2>
                                    <div class="section_toggle_swap">
                                          <div class="article summary">
                        Mount Isa local Lucky Luke is the hometown hero opening up triple j&#039;s One Night Stand                      </div>
                                                                  <hr />

                                          </div>
                <a class="btn btn_more" title="More" href="/competition/triple-js-one-night-stand-2017">More</a>
                    </div>
                    <div class="footer340"></div>
                  </div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
</div>
  </div>
  
  <div class="panel-panel panel-col-third">
    <div class="inside content_module_container"><div class="panel-pane pane-block pane-views-df884c66ab5c44ce61066b015c9df95e" >
  
      
  
  <div class="view view-artist-reviews-triple-j-users view-id-artist_reviews_triple_j_users view-display-id-block view-dom-id-28820fd00ae822666f55a48b722517c7">
        
  
  
      <div class="view-content">
      <div class="content_module module_review clearfix">
    <div class="outline">
    <h3>Review</h3>
    <div class="summary">
      <h4 class="track"> Jacks  </h4>
      <h2 class="band"><a href="/artist/lucky-luke">Lucky Luke </a></h2>
      <div class="play_actions">

        <a href="/jukebox/play/track/5858731" class="play_now_large open_jukebox" title="Play now">Play now</a>
        <a href="/jukebox/queue/track/5858731" class="play_add_large open_jukebox" title="Add to Listening Queue">Add to Listening Queue</a>
        <a href="/download/track/5858731" class="play_download_large" title="Download now">Download now"</a>
      </div>
    </div>

    <div class="separator"></div>

    <div class="reviewer">

      
      <a class="photo" href="/user/2044301">  <img src="/sites/default/files/styles/unearthed_small/public/users/public/2/0/4/4/3/0/1/1ca48684-b0e1-4724-9ca5-aeb39f82a69d.jpg" width="50" height="33" alt="Review by Max Quinn"> </a>
      
            <a href="/user/2044301" class="reviewer_name">
          Max Quinn </a>
            <p class="review_date">

        19 Apr 2017      </p>

            <div class="icons playedontriplej">
        Triple J
      </div>

      
    </div>

    <div class="review_box_top">

    </div>

    <div class="review_box">
              <div class="stars stars40">
          40        </div>
                            <div class="review content_summary"><p>What a dude and what a jam.</p>
</div>
        <div class="review content_full"><p>What a dude and what a jam.</p>
</div>

          </div>
      </div>
  <div class="footer220"></div>
</div>
<div class="content_module module_review clearfix">
    <div class="outline">
    <h3>Review</h3>
    <div class="summary">
      <h4 class="track"> Jacks  </h4>
      <h2 class="band"><a href="/artist/lucky-luke">Lucky Luke </a></h2>
      <div class="play_actions">

        <a href="/jukebox/play/track/5858731" class="play_now_large open_jukebox" title="Play now">Play now</a>
        <a href="/jukebox/queue/track/5858731" class="play_add_large open_jukebox" title="Add to Listening Queue">Add to Listening Queue</a>
        <a href="/download/track/5858731" class="play_download_large" title="Download now">Download now"</a>
      </div>
    </div>

    <div class="separator"></div>

    <div class="reviewer">

      
      <a class="photo" href="/user/1725281">  <img src="/sites/default/files/styles/unearthed_small/public/users/public/1/7/2/5/2/8/1/ec89b9d6-4b5d-4087-be53-64c1f2a67340.jpg" width="50" height="33" alt="Review by Celline Narinli"> </a>
      
            <a href="/user/1725281" class="reviewer_name">
          Celline Narinli </a>
            <p class="review_date">

        10 Apr 2017      </p>

            <div class="icons playedontriplej">
        Triple J
      </div>

      
    </div>

    <div class="review_box_top">

    </div>

    <div class="review_box">
              <div class="stars stars40">
          40        </div>
                            <div class="review content_summary"><p>Absolutely solid stuff man. Contagious beat and drive all the way through to the end.</p>
</div>
        <div class="review content_full"><p>Absolutely solid stuff man. Contagious beat and drive all the way through to the end.</p>
</div>

          </div>
      </div>
  <div class="footer220"></div>
</div>
<div class="content_module module_review clearfix">
    <div class="outline">
    <h3>Review</h3>
    <div class="summary">
      <h4 class="track"> Jacks  </h4>
      <h2 class="band"><a href="/artist/lucky-luke">Lucky Luke </a></h2>
      <div class="play_actions">

        <a href="/jukebox/play/track/5858731" class="play_now_large open_jukebox" title="Play now">Play now</a>
        <a href="/jukebox/queue/track/5858731" class="play_add_large open_jukebox" title="Add to Listening Queue">Add to Listening Queue</a>
        <a href="/download/track/5858731" class="play_download_large" title="Download now">Download now"</a>
      </div>
    </div>

    <div class="separator"></div>

    <div class="reviewer">

      
      <a class="photo" href="/user/2013136">  <img src="/sites/default/files/styles/unearthed_small/public/users/public/2/0/1/3/1/3/6/456dca53-1db9-43e6-a989-665c05dc286b.jpg" width="50" height="33" alt="Review by Richard Kingsmill"> </a>
      
            <a href="/user/2013136" class="reviewer_name">
          Richard Kingsmill </a>
            <p class="review_date">

        07 Apr 2017      </p>

            <div class="icons playedontriplej">
        Triple J
      </div>

      
    </div>

    <div class="review_box_top">

    </div>

    <div class="review_box">
              <div class="stars stars40">
          40        </div>
                            <div class="review content_summary"><p>Solid delivery, and loving the beats and sample he&#039;s used here. After the One Night Stand, Lucky Luke will put Mount Isa on the hip hop map.</p>
</div>
        <div class="review content_full"><p>Solid delivery, and loving the beats and sample he&#039;s used here. After the One Night Stand, Lucky Luke will put Mount Isa on the hip hop map.</p>
</div>

          </div>
      </div>
  <div class="footer220"></div>
</div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-block pane-views-1db444a7507409e78d3403657541a5bd" >
  
      
  
  <div class="view view-artist-reviews-non-triple-j-users view-id-artist_reviews_non_triple_j_users view-display-id-block view-dom-id-d277f72d9791ca121ce2009d927ceed9">
        
  
  
  
  
  
  
  
  
</div>
  
  </div>
<div class="panel-pane pane-block pane-views-932a6b7644d1360fec4c98791c5cd468" >
  
      
  
  <div class="view view-artist-review-module-block view-id-artist_review_module_block view-display-id-block view-dom-id-27c81a6dc44a8da2ec6022178116938e">
        
  
  
      <div class="view-content">
      <div class="content_module module_morereviews">
  <a href="/artist/5608716/reviews" title="More Reviews" class="more_reviews">More Reviews</a>
</div>
    </div>
  
  
  
  
  
  
</div>
  
  </div>
</div>
  </div>  
  
</div>
            </div>
          </div>
                </div>
    </div>
    <div id="navigation">
          </div>

    
    
  </div>

      <div id="unearthed-footer">
      <div class="footer-top">
        <div class="menu">
          <ul>
            <li>
              <ul>
                <li><a href="/comps-and-resources/resources">Articles</a></li>
                <li><a href="/discover/charts">Charts</a></li>
                <li><a href="/discover/gigs">Gigs</a></li>
                <li><a href="/digital-radio/programs">Programs</a></li>
                <li><a href="/comps-and-resources/competitions">Competitions</a></li>
              </ul>
            </li>
            <li>
              <a href="/discover/artists">Music</a>
              <ul class="submenu">
                <li><a href="/discover/artists?featured=featured">Featured Artists</a></li>
                <li><a href="/discover/tracks?played=triplej">Played on Triple J</a></li>
                <li><a href="/discover/tracks?played=unearthed">Played on Unearthed</a></li>
              </ul>
            </li>
            <li>
              <a href="/discover/reviews">Reviews</a>
              <ul class="submenu">
                <li><a href="/discover/reviews?featured=triplej">Triple J Team</a></li>
                <li><a href="/discover/reviews?featured=guest">Guest Hosts</a></li>
                <li><a href="/discover/reviews?featured=super-user">Super Users</a></li>
              </ul>
            </li>
            <li>
              <a href="/discover/playlists">Playlists</a>
              <ul class="submenu">
                <li><a href="/discover/playlists?featured=triplej">Triple J Team</a></li>
                <li><a href="/discover/playlists?featured=guest">Guest Hosts</a></li>
                <li><a href="/discover/playlists?featured=super-user">Super Users</a></li>
              </ul>
            </li>
          </ul>
        </div>
        <div class="site-links">
          <ul>
            <li><a href="/comps-and-resources/about">About</a></li>
            <li><a href="/comps-and-resources/help">Help &amp; FAQs</a></li>
            <li><a href="/comps-and-resources/contact" rel="lightframe [|width:800px; height:410px;]">Contact Us</a></li>
            <li><a href="/comps_resources_subscribe" rel="lightframe [|width:800px; height:300px;]">Newsletter</a></li>
          </ul>
        </div>
        <div class="social">
          <ul class="social-links">
            <li><a target="_blank" class="facebook" href="http://www.facebook.com/triplejunearthed" title="Facebook"><span class="hidden">Facebook</span></a></li>
            <li><a target="_blank" class="tumblr" href="http://triplejunearthed.tumblr.com/" title="Tumblr"><span class="hidden">Tumblr</span></a></li>
            <li><a target="_blank" class="twitter" href="http://twitter.com/triplejunearthd" title="Twitter"><span class="hidden">Twitter</span></a></li>
            <li><a target="_blank" class="youtube" href="https://www.youtube.com/playlist?list=PLFDB72A88875955B1" title="YouTube"><span class="hidden">YouTube</span></a></li>
            <li><a target="_blank" class="instagram" href="https://instagram.com/triple_j_unearthed" title="Instagram"><span class="hidden">Instagram</span></a></li>
            <li><a target="_blank" class="soundcloud" href="https://soundcloud.com/triplejunearthed" title="Soundcloud"><span class="hidden">Soundcloud</span></a></li>
          </ul>
          <div class="app-links">
            <span>Download the triple j Unearthed app:</span>
            <ul>
              <li><a target="_blank" class="android" href="https://play.google.com/store/apps/details?id=au.net.abc.unearthed" title="Android"><span class="hidden">Android</span></a></li>
              <li><a target="_blank" class="ios" href="https://itunes.apple.com/au/app/triple-j-unearthed-mobile/id348746923" title="iOS"><span class="hidden">iOS</span></a></li>
            </ul>
          </div>
        </div>
        <div class="badges-key">
          <ul>
            <li>
              <span class="icons mature" title="Strong impact coarse language and/or themes"></span>
              <span> = strong content</span>
            </li>
            <li>
              <span class="icons unearthed" title="Played on Unearthed"></span>
              <span> = played on unearthed</span>
            </li>
            <li>
              <span class="icons playedontriplej" title="Played on triple j"></span>
              <span> = played on triple j</span>
            </li>
          </ul>
        </div>
      </div>
      <div class="footer-abc">
        <div class="menu">
          <ul>
            <li><a href="/privacy-policy" title="Privacy Policy">Privacy Policy</a></li>
            <li><a href="/terms-and-conditions" title="User Terms &amp; Conditions">User Terms &amp; Conditions</a></li>
            <li><a href="http://www.abc.net.au/" title="&copy; ABC">&copy; ABC</a></li>
          </ul>
        </div>
        <div class="links">
          <ul>
            <li><a target="_blank" href="http://www.abc.net.au/triplej/" title="triple j">
                <span class="hidden">triple j</span>
                <img src="/profiles/unearthed_profile/themes/unearthed_theme/images/logo_triplej.png" alt="triple j">
              </a></li>
            <li><a target="_blank" href="http://doublej.net.au/" title="Double J">
                <span class="hidden">Double J</span>
                <img src="/profiles/unearthed_profile/themes/unearthed_theme/images/logo_doublej.png" alt="triple j">
              </a></li>
          </ul>
        </div>
      </div>
    </div>

  </div>

</div>
        <script src="https://www.triplejunearthed.com/sites/default/files/js/js_ndbJmRgTk7tdRyIJIuI_OcSE2gQ72GyhdQv75VCxREI.js"></script>
<script src="https://www.triplejunearthed.com/sites/default/files/js/js_Su13GXyZ0tPiTiXKR6pxnsphAo8xhNC4RFJWP55ZwbU.js"></script>
<script>var $ = jQuery.noConflict();</script>
<script src="https://res.abc.net.au/bundles/2.0.9/scripts/abc.bundle.2.0.9.min.js"></script>
        <script>
          (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function() {
            (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new
              Date();a=s.createElement(o),
              m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(
              a,m)
          })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
          ga('create', 'UA-26263635-7', 'auto');
          ga('send', 'pageview');
        </script>
        <!-- START Nielsen Online SiteCensus V6.0 -->
        <!-- COPYRIGHT 2010 Nielsen Online -->
        <script type="text/javascript" src="//secure-au.imrworldwide.com/v60.js"></script>
        <script type="text/javascript">
          var pvar = { cid: "abc-aust", content: "0", server: "secure-au" };
          if (typeof nol_t === 'function') {
            var trac = nol_t(pvar);
            trac.record().post();
          }
        </script>
        <noscript><div><img src="//secure-au.imrworldwide.com/cgi-bin/m?ci=abc-aust&cg=0&cc=1&ts=noscript" width="1" height="1" alt=""></div></noscript>
        <!-- END Nielsen Online SiteCensus V6.0 -->
    </body>
</html>
